PPAs Incompatible with Linux Mint 17.1 Rebecca

The following PPAs are incompatible with Linux Mint 17.1 Rebecca (Ubuntu 14.10 Utopic Unicorn) as of 2016/12/20 12:53.

  • ppa:caffeine-developers/ppa - Needed to install caffeine, a screensaver blocking application for flash video.
  • http://www.bunkus.org - The software will not install using the Utopic deb sources due to dependencies unable to be installed (libstdc++6 (>= 4.9), libwxbase3.0-0, libwxgtk3.0-0 (>= 3.0.1)). Use the trusty sources instead.

The only way to install packages available in these repositories is to use the repositories from the closest distribution. Support may be available in the coming months.

In order to install applications in Linux Mint 17.1 Rebecca/ Ubuntu 14.10, the source files for these repositories must be modified to point to the closest lower distribution instead of utopic.

Example:

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo vi /etc/apt/sources.list.d/caffeine-developers-ppa-trusty.list
[update distribution name from trusty to raring]
sudo apt-get update
sudo apt-get install caffeine

Do not forget to set the repositories back to utopic once the distribution is officially supported by the respective repositories.